백준 10845번: 큐
by Jm Park
문제
정수를 저장하는 큐를 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.
명령은 총 여섯 가지이다.
- push X: 정수 X를 큐에 넣는 연산이다.
- pop: 큐에서 가장 앞에 있는 정수를 빼고, 그 수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
- size: 큐에 들어있는 정수의 개수를 출력한다.
- empty: 큐가 비어있으면 1, 아니면 0을 출력한다.
- front: 큐의 가장 앞에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
- back: 큐의 가장 뒤에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
입력
첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.
출력
출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.
예제 입력/출력
예제 입력 | 예제 출력 |
---|---|
15 push 1 push 2 front back size empty pop pop pop size empty pop push 3 empty front |
1 2 2 0 1 2 -1 0 1 -1 0 3 |
코드
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <string>
#include <vector>
using namespace std;
vector<int> que;
vector<int> ans;
int main() {
int n;
string str;
scanf("%d", &n);
que.reserve(n+5);
ans.reserve(n+5);
cin.ignore(); // 입력버퍼 비움
for (int i = 0; i < n; i++) {
getline(cin, str);
if (!str.compare("pop")) {
if (que.empty())
ans.push_back(-1);
else {
ans.push_back(que.front());
que.erase(que.begin());
}
}
else if (!str.compare("size"))
ans.push_back(que.size());
else if (!str.compare("empty")) {
if (que.empty())
ans.push_back(1);
else
ans.push_back(0);
}
else if (!str.compare("front")) {
if (que.empty())
ans.push_back(-1);
else
ans.push_back(que.front());
}
else if (!str.compare("back")) {
if (que.empty())
ans.push_back(-1);
else
ans.push_back(que.back());
}
else if(str.find("push") != string::npos) {
str.erase(0, 5);
que.push_back(atoi(str.c_str()));
}
}
for (vector<int>::iterator i = ans.begin(); i < ans.end(); i++)
cout << *i << '\n';
return 0;
}
풀이
단순히 if-else문으로 입력받은 명령문에 알맞은 명령을 처리하면 된다.
구현을 하면서 실수했던 부분은 “cin.ignore()” 입력 버퍼를 비우는 것이었다. 버퍼가 비워지지 않아 for문을 총 n번 돌아야 하지만 n-1번 돌아 에러가 났었다. 참고자료
Subscribe via RSS